Excel 2016: Basics 1
Navigating and Formatting
In this workshop, we will learn keyboard and mouse shortcuts to quickly move through the worksheets and to format the cells. Topics include an introduction to the Excel interface; working with selections; entering and editing data in cells; cut and copy vs. move and duplicate; resizing, inserting and deleting columns and rows; formatting cell fonts, alignments, numbers, borders and shading. Lots of shortcuts! This basic workshop assumes some experience with Microsoft Excel.

<table>
<thead>
<tr>
<th>Text Modes</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Moving Between Cells</td>
<td>1</td>
</tr>
<tr>
<td>Navigating using the keyboard</td>
<td>1</td>
</tr>
<tr>
<td>Enter Key</td>
<td>1</td>
</tr>
<tr>
<td>Tab Key</td>
<td>1</td>
</tr>
<tr>
<td>Page Up and Page Down Keys</td>
<td>1</td>
</tr>
<tr>
<td>Arrow Keys</td>
<td>2</td>
</tr>
<tr>
<td>Home Key</td>
<td>2</td>
</tr>
<tr>
<td>End Key</td>
<td>2</td>
</tr>
<tr>
<td>Escape Key</td>
<td>2</td>
</tr>
<tr>
<td>Delete Key</td>
<td>3</td>
</tr>
<tr>
<td>Backspace Key</td>
<td>3</td>
</tr>
<tr>
<td>Navigating Using the Mouse</td>
<td>3</td>
</tr>
<tr>
<td>Single-Click</td>
<td>3</td>
</tr>
<tr>
<td>Double-Click</td>
<td>3</td>
</tr>
<tr>
<td>Navigating Using the Mouse and Keyboard</td>
<td>3</td>
</tr>
<tr>
<td>Shift-Click</td>
<td>3</td>
</tr>
<tr>
<td>Ctrl-Click</td>
<td>3</td>
</tr>
<tr>
<td>Undo and Redo</td>
<td>3</td>
</tr>
<tr>
<td>Undo</td>
<td>4</td>
</tr>
<tr>
<td>Redo</td>
<td>4</td>
</tr>
<tr>
<td>Zoom Slider</td>
<td>4</td>
</tr>
<tr>
<td>The Clipboard</td>
<td>4</td>
</tr>
<tr>
<td>Clipboard</td>
<td>4</td>
</tr>
<tr>
<td>Cut</td>
<td>5</td>
</tr>
<tr>
<td>Copy</td>
<td>5</td>
</tr>
<tr>
<td>Moving and Duplicating with the Mouse</td>
<td>5</td>
</tr>
<tr>
<td>Fill Handle</td>
<td>5</td>
</tr>
<tr>
<td>Format Painter</td>
<td>6</td>
</tr>
<tr>
<td>Paste</td>
<td>6</td>
</tr>
<tr>
<td>Paste Values</td>
<td>6</td>
</tr>
<tr>
<td>Other Paste Options</td>
<td>6</td>
</tr>
</tbody>
</table>
Microsoft Excel: Basics 1 - Navigating and Formatting

2.0 hours

Paste Special ................................................................................................................. 7
A Note About the Ribbon ............................................................................................... 8
Formatting Cells ........................................................................................................... 8
  Font - Ribbon ........................................................................................................... 8
  Font - Format Cells Window ..................................................................................... 9
  Border - Format Cells Window .................................................................................. 9
  Line ......................................................................................................................... 9
  Presets .................................................................................................................... 9
  Border ...................................................................................................................... 9
Fill - Format Cells Window .......................................................................................... 10
  Background Color ................................................................................................. 10
  Fill Effects ............................................................................................................ 10
  Patterns .................................................................................................................. 10
Alignment - Ribbon ..................................................................................................... 11
Alignment - Format Cells Window ............................................................................... 11
  Text Alignment .................................................................................................... 11
  Orientation ........................................................................................................... 12
  Text Control ........................................................................................................ 12
  Right to Left .......................................................................................................... 12
Number - Ribbon ........................................................................................................ 13
Number - Format Cells Window .................................................................................. 13
Shortcut Keys .............................................................................................................. 16
Class Exercise ............................................................................................................. 17
Text Modes

There are three basic text modes in Excel. The current mode can be found on the status bar, at the bottom left corner of the Excel Window.

- Excel is begins in **Ready** mode. This means nothing is being entered or edited on the spreadsheet. In **Ready** mode, the keyboard arrows, and home/end keys will move you between cells.

- Excel changes to **Enter** mode when you begin to enter data into the cell. You can type directly into any current cell, or double-click on an empty cell to be in Enter mode. In **Enter** mode, the keyboard arrows, and home/end keys will move you between cells.

- Excel changes to **Edit** mode when you double-click on a cell with data in it, when you click inside the formula bar or when you press the **F2** key on the keyboard, (**F2** will also toggle you between **Edit** and **Enter** mode). **Edit** mode allows you to use the keyboard arrows, and home/end keys to move among the characters within the cell.

Moving Between Cells

Navigating using the keyboard

**Enter Key**

The **Enter** (sometimes called the Return) key will move the focus down one cell. If you are in **Edit** or **Enter** mode, Excel will accept changes and move down.

- Using the **Shift** key and the **Enter** key will move the focus up one cell.
- Using the **Ctrl** key and the **Enter** key will accept changes and remain on the current cell. This is the same as clicking the ✓ in front of the formula bar.
  - Inside a selection, **Ctrl-Enter** will fill in the contents of the cell being edited into every cell in the selection.
- Using the **Alt** key and the **Enter** key will put in a hard return and force the cell to move to a second line.

**Tab Key**

The **Tab** key moves the focus one cell to the right. If you are in **Edit** or **Enter** mode, Excel will accept changes and move right.

- Using the **Shift** key and the **Tab** will move the focus one cell left.
- Using the **Ctrl** key and the **Tab** will move you to another Workbook (another Excel file).
- Using the **Alt** key and the **Tab** will move you to another open program on your computer.

**Page Up and Page Down Keys**

The **Page Up** and **Page Down** keys will move the focus of the current cell to the last visible cell on the previous screen, that is, it moves down one "screenful" of cells.

- Using the **Ctrl** key and the **Page Up** or **Page Down** keys will move to the previous or next Worksheet, respectfully.
- Using the **Alt** key and the **Page Up** or **Page Down** keys moves a "screenful" left or right, respectively.
Arrow Keys

In Ready mode and in Enter mode the arrow keys will move in the direction they point: up, down, left and right by one cell.

- Using the Shift key and the arrows will select a range of cells as you move.
- Using the Ctrl key and the arrows will move the current cell to the edge of the current data region (where the data stops/starts).
  - Using both the Shift-Ctrl and the arrows keys will select all the cells from the current cell to the edge of the current data region.

In Edit mode the arrow keys will move you up, down, left and right between the letters and lines within the cell (if you only have one line of text the up and down arrows have no effect).

- Using the Shift key and the arrows will select text in that direction
- Using the Ctrl key and the left and right arrows will move word by word
  - Shift-Ctrl and the left and right arrows will select text, word by word

Home Key

In Ready and Enter mode, the Home key moves to the first column within that row.

- Using the Shift key and the Home key will select from the current cell to the first column within that row.
- Using the Ctrl key and the Home key will move to the very top of your worksheet.
  - Shift-Ctrl-Home will select from the current cell to the very top of the worksheet

In Edit mode, the Home key moves to the beginning of the cell.

- Using the Shift key and the Home key will select from where the cursor is blinking to the beginning of the cell.

End Key

In Ready mode, the End key turns on an End feature. You will see the "END" appear on the status bar. Once it's on, you can then press an arrow key and it will search in that direction for a change in the cell pattern (with/without data). A similar method can be used by simply using the Ctrl key and the directional arrow.

- Ctrl-End moves to the last working cell on the worksheet, which is the cell at the intersection of the right-most used column and the bottom-most used row (in the lower-right corner)
  - Shift-Ctrl-End will select from the current cell to the last (working) cell on the spreadsheet

In Edit mode, the End key moves to the end of the cell.

- Using the Shift key and the End key will select from where the cursor is blinking to the end of the cell.

Escape Key

The Esc (escape) key is the cancel button; if you are editing/entering data in a cell, escape will ignore any changes you have made and return you to the original data or blank cell. This is the same as clicking the x in front of the formula bar. Esc will close dialog boxes such as Open, and Save As.
Delete Key

In Ready mode, the Delete key will erase the contents of the cell, not the formatting. To erase the formatting as well, you will need to right-click and choose Delete... or choose Delete from the Home Tab to literally delete the cell from the worksheet. When you do this, you will need to tell Excel where to shift the other cells.

In Enter and Edit mode, the Delete key will erase characters to the right of the cursor.

Backspace Key

In Ready mode the Backspace key will erase the contents of the cell and put you into enter mode.

In Enter and Edit mode, Excel will erase characters to the left of the cursor.

- Delete is more universally used throughout Windows to remove objects such as images, table cell contents and files. Backspace is used fundamentally for text only.

Navigating Using the Mouse

Single-Click

In Ready mode, clicking on any cell will make it the current cell. In Enter or Edit mode, clicking on a cell will make it the current cell as long as you are not trying to build an equation. If you start a cell with an equals (=), plus (+), or minus (-), Excel will think you are trying to do math. Now a Single-Click will change to a Point mode, allowing you to choose cells for use in your equation.

Double-Click

Double-clicking on an empty cell will put the cell into Enter mode; double-clicking on a cell with data in it will put the cell in Edit mode.

Navigating Using the Mouse and Keyboard

Shift-Click

If you use Shift key and the mouse, you can select a range (a set of conjoining cells). Click where you want to start, hold down the Shift key and click where you want to stop. Every cell in between will be selected.

Ctrl-Click

If you use the Ctrl key and the mouse, you can select various cells (skipping ones in between). You cannot use these for equations but you can apply formatting (i.e. change several cells to red text).

Undo and Redo

Microsoft Excel keeps track of almost every task you perform. If you accidentally delete or change something you did not mean to, you can usually Undo whatever you have just done. Excel allows you to Undo multiple times, and even to Redo things. The Redo allows you to undo the undo.
**Undo**

The **Undo** feature is used to go back one-step. This button shows an arrow looping counterclockwise. The short-cut key is **Ctrl-Z** and the button in the quick access toolbar at the top of the window.

To do multiple Undo's at once you can click the dropdown arrow next to the undo button and see the list of actions you have performed. You cannot go back and undo a task without undoing all the steps that lead up to that point.

**Redo**

The **Redo** feature is used to go forward one-step. This button shows an arrow looping clockwise. The short-cut key is **Ctrl-Y** and the button can be found in the quick access toolbar at the top of the window.

To Redo multiple times, you can click the dropdown arrow next to the redo button and see the list of actions you have undone. You cannot go back and undo a task without undoing all the steps that lead up to that point.

* If there is nothing to redo, Excel puts a **Repeat** feature in Redo's place and assigns the short cut key (Ctrl-Y) to Repeat. For example, if you delete a row, the repeat row will allow you to delete another and another...

**Zoom Slider**

In the bottom, right corner of your status bar is a Zoom Slider. The percent can be set between 10% and 400%.

- The plus will zoom in and make the worksheet appear larger; the minus will zoom out and make the worksheet appear smaller. This does not change the printout, only the view.
- If you click on the percentage value (100%), the Zoom window will open.

**The Clipboard**

Cut, Copy and Paste are clipboard features built into Windows. The clipboard is a temporary storage place for pictures and data. The Windows clipboard can only store one item at a time. Microsoft Office has a Multi-Clipboard that can store 24 items, but the Paste button and the shortcuts for the Paste option only correspond to the most recently copied item. The clipboard pane must be displayed to be able to use this feature.

**Clipboard**

If you click the "more" arrow to the right of the word **Clipboard** it will open the Clipboard Panel.

Once the clipboard is open you will see the pane fill with a new item each time you cut or copy. To retrieve an item from the pane, click on the text/item you wish to paste, and it will appear in the selected cell. If you would like to paste all the cells in the order in which they appear you can click the **Paste All** button. The **Clear All** button will erase all items in the clipboard.

To Close the Clipboard, click the Clipboard's "more" arrow, or use the x in the upper right corner of the clipboard pane.
Cut
The Cut feature is used to move cells. This button appropriately shows a pair of scissors for the cut option. The short-cut key is Ctrl-X.

To use the Cut command, you need to first select the cell or a set of conjoining cells, and then choose the Cut option. When you choose Cut a dashed line marquee (marching ants) will surround the cells, but the data in the cells will still be visible. Click into the cell where you want the upper left most part of your selection to be moved to and press Enter or choose Paste. Your selection will appear in the designated cell(s), and at the same time disappear from the original location. If your clipboard is not open, you will not be able to Paste again.

Copy
The Copy feature is used to duplicate cells. This button appropriately shows two sheets of paper for the copy option. The short-cut key is Ctrl-C.

To use the Copy command, you need to first select the cell or a set of conjoining cells and then choose the Copy option. When you choose Copy, a dashed line marquee (marching ants) will surround the selected cells. Click into the cell where you want the upper left most part of your selection to appear and press Enter or choose Paste.

- If you choose Enter, the dashed line marquee will disappear from your original selection and you will have a duplicate in the designated spot. If your clipboard is not open, you will not be able to Paste again.

- If you choose one of the Paste options, the duplicate will appear, but the dashed line marquee continues around your original selection, this is so you can continue to make copies by pasting. You will be able to paste as long as the original selection has the dashed line marquee.

Moving and Duplicating with the Mouse
If you put your mouse over the border of the selected cell(s), you will get the Select Arrow.

- Hover over the border and drag (don’t let go of the mouse) and a shadow will follow your mouse. Let go in an empty cell and the selected cell will be Moved to the new location. This is an alternative to cut.

- Use the Ctrl button while dragging the mouse and you will see a small plus sign added to the shadow. Drag the to an empty cell, be sure to let go of the mouse before the keyboard and Excel will duplicate the selection instead of moving it. This is an alternative to copy.

Fill Handle
The Fill Handle is in the bottom right corner of the selected cell. When you place your mouse over this handle, it changes from a thick white selection cross, to a thin black cross. Once you see the darker cross, you can click and drag the cell to fill the original cell’s contents into the newly selected cells. The handle allows the mouse to move in a single direction (up, down, left or right). If you want to go in two directions, you must first complete one way, let go of the mouse and then drag again in the second direction.

When you use the Fill Handle to pull down a single number or plain text, it will copy the data.

This is discussed more in depth in the Excel Basics II – Math and Functions workshop handout.
**Format Painter**

The clipboard group has a button called the **Format Painter**. The **Format Painter** copies the format of selected cells and applies the format to the cells you specify. This button appropriately shows a paintbrush.

**Paste**

When you are copying a cell, the paste button has a long list of possibilities. If you click on the clipboard button itself, it performs the same action as the very first paste option on its pasting menu.

- **Paste** will paste the copied cell contents and formatting
- **Formulas** will paste the formulas without formatting
- **Formulas and Number Formatting** will paste the copied cell contents and number formatting
- **Keep Source Formatting** will paste the copied cell contents, number formatting, and cell formats
- **No Borders** will paste the cell contents and formatting, but no borders
- **Keep Source Column Widths** will paste the cell contents, formatting and cell width
- **Transpose** will paste a horizontal set of cells into a vertical set of cells, or a vertical set of cells into a horizontal set of cells

**Paste Values**

- **Paste Values** will paste the unformatted values instead of the formulas
- **Paste values and number formats** will paste the raw values instead of the formulas, but with the number format from the original cells
- **Values and Source Formatting** will paste the raw values instead of the formulas, but with the number format and cell formats from the original cells

**Other Paste Options**

- **Formatting** will paste only the formatting from the original cells, not the contents (Format Painter)
- **Paste Link** will link the new cell to the old such that any changes to the old data will be made here
- **Paste Picture** will create a floating picture based on the copied cells
- **Paste Linked Picture** will create a floating picture based on the copied cells that are linked to the original value so changes made in the original data will be reflected in the picture.
**Paste Special**

The **Paste Special** option can be found on the shortcut (right-click) menu, and the **Paste** dropdown menu (see previous page). If this option is grayed out, it means that nothing is currently on the clipboard. If the copied item is from outside of Excel, you will get a customized screen to paste as text, pictures, or links. If you have copied from inside of Excel, you will get the following options.

- **All**: paste cell contents and formatting
- **Formulas**: paste the formulas staying true to the absolute and relative references
- **Values**: paste only the raw numbers
- **Formats**: pastes only cell formatting
- **Comments**: pastes comments attached to the cell, but not the data
- **Validation**: pastes data validation rules for the copied cells to the paste area
- **All using Source theme**: pastes only theme of original cells
- **All except borders**: pastes cell contents and all formatting except the border lines surrounding the original cells
- **Column widths**: pastes the width of a column (or range) to another column (or range)
- **Formulas and number formats**: pastes formulas and all number formatting
- **Values and number formats**: pastes the raw numbers and number formatting
- **All merging conditional formats**: pastes formulas, formatting and conditional formatting

**Operation Options**

- The Paste Special Operation option allows you to specify a mathematical operation.
  
  - **Example**: A1:A2 are copied onto B1:B2, using an Add Operation

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Other Options**

- **Skip blanks** - Avoids replacing values in your paste area when blank cells occur in the copy area.
- **Transpose** - Changes columns of copied data to rows, and rows of copied data into columns.
- **Paste Link** - Links the pasted data to the active worksheet.
A Note About the Ribbon

The images of Excel in this packet were copied from a wide screen monitor. With the wide screen, the ribbon is stretched across the window and I can see all the buttons. If you are working on a narrower window, Excel will try to clump the groups together and the layout may look a little different from the ones shown here, but all the buttons will be there.

Here we can see how the font group is now three buttons high, and how some of the buttons like Wrap Text have lost their text labels.

Formatting Cells

The most formatting options are found on the Home Tab. All the options are in the Format Cells window. This contains several tabs to help us format the contents of our spreadsheet. This window can be opened by using the More Options button at the end of the Format, Alignment and Number groups. You can also use the Keyboard Shortcut – Ctrl-1 or choose Format Cells… from the right-click shortcut menu.

Font - Ribbon

1. **Font** – Sets the font of the selected cell(s). Fonts are different ways to show the same letters.
2. **Font Size** – Sets the size of the letters (the font). Larger numbers give larger fonts. You can type a custom size into this box. Excel will allow you to use the numbers 1 through 409, including half sizes.
3. **Increase Font** – Increases the font to the next Font Size on the list
4. **Decrease Font** – Decreases the font to the next Font Size on the list
5. **Bold** – Makes the selected cell(s) **Bold**. Shortcut keys are Ctrl-B and Ctrl-2.
6. **Italic** – Makes the selected cell(s) *Italicized*. Shortcut keys are Ctrl-I and Ctrl-3.
7. **Underline** – Makes the selected cell(s) Underlined. Shortcut keys are Ctrl-U and Ctrl-4. The drop down arrow lets you choose between single and double underlines.
8. **Borders** – Adds and removes borders for the selected cell(s). The drop down arrow will provide a long menu of border possibilities. To get to the dialog box for more control you can choose More Borders…
9. **Fill Color** – Changes the background color of the selected cell(s). By default, the cells have "No Fill"; this is not the same as a White Background.
10. **Font Color** – Changes the color of the font of the selected cell(s).
11. More Options – This button will open the Format Cells dialog window.
Font - Format Cells Window

- **Font** sets the font, the shape of the letters of the selected cell(s) or text.
- **Font Style** offers four options. Regular, *Italic*, **Bold**, **Bold Italic**.
- **Size** sets the size of the letters (the font).
- **Underline** places a line under the data.
- **Color** changes the color of the font.
- **Normal Font** will reset the selected cells to the default values, which are set in the Excel Options.
- **Strikethrough** places a single line through the value in the cell.
- **Superscript** raises and shrinks the selected text, used in text like 3rd and x². (Superman goes up)
- **Subscript** lowers and shrinks the text, used in text such as H₂O and HA₁C. (Subway goes down)

Border - Format Cells Window

By default, the gridlines around the cells of your spreadsheet do not print. If you would like them to print, you can turn them on from the Page Layout Tab; click the Print check box under the Gridlines option.

The Font group of the Home Tab has a borders button 📒. This button has multiple border options, but for more customizations, you can come to this window.

**Line**
You can choose a line style and a line color that you would like for your border. The line style/color you choose will not be applied until you choose a Preset or a Border option.

**Presets**
There are three preset border options: None (no borders), Outline (Top, left, right, bottom borders), and Inside (inner borders). These will be created based on the line style and color selected.

**Border**
The Border group does more than show a preview of the preset options, it allows you to choose to turn on or off any border (top, middle, bottom, diagonal left, left, center, right, diagonal right). Select the line style and color and then click within the preview window, or on the actual border button to see the change. To turn off the border, click on the border or border button again, or choose the **None** option from the Presets.
**Fill - Format Cells Window**

By default, the cell background has no color. The Font group of the Home Tab has a fill button. This button has multiple fill options, but for more control, you can open the Format Cells Window.

**Background Color**

The Background Color shows the same palette of colors we see on the Home Tab. Click on a color to choose it as your new background color.

**More Colors...** If the color palette is not sufficient, you can use the More Colors button. This will give you a honeycomb of multiple color options. If you want to go even deeper, you can choose to **Custom** build a color.

**Fill Effects...**

The gradient gives the cells more depth of color by showing almost a 3-D effect as it changes one color to another.

**Patterns**

A pattern allows us to put lines and hash marks in the background of our cell(s). Along with the pattern that will fill in the background, you have the ability to choose the Pattern Color.
Alignment - Ribbon

1. **Top Align** – Vertically aligns to the top of the cell.
2. **Middle Align** – Vertically aligns to the middle of the cell.
3. **Bottom Align** – Vertically aligns to the bottom of the cell.
4. **Orientation** – Rotates the contents of the cell to the currently displayed option.
5. **Wrap Text** – Displays contents on multiple lines within the cell's column width.
6. **Align Text Left** – Horizontally aligns the contents to the left side of the column.
7. **Center** – Horizontally aligns the contents to the center of the cell.
8. **Align Text Right** – Horizontally aligns the contents to the right side of the cell.
9. **Decrease Indent** – Decreases the space between the text and the cell border for Left, Right and Distributed horizontal alignments.
10. **Increase Indent** – Increases the space between the text and the cell border for Left, Right and Distributed horizontal alignments.
11. **Merge and Center** – Joins selected (adjacent) cells into one cell and centers the result. If there is data in more than one cell, Excel will only keep the information from the upper left cell. The drop down arrow offers a few more options, including Merge Cells and Unmerge Cells. **Merge and Center** will merge the cells from the rows and columns into one large cell. The **Merge Across** option will merge the cells across the columns but not the rows.
12. **More Options** – This button will open the Format Cells dialog window to the Alignment Tab.

Alignment - Format Cells Window

**Text Alignment**

**Horizontal**: By default, Excel has a **General** Horizontal Format, this means that Text is aligned left and numbers are aligned right.

- **Fill** will repeat the contents of the cell as many times as will fit within the width of the column.
- **Justify** keeps the text even on both sides of the cell, as a "full justified" paragraph.
- **Center Across Selection** will center the text in the first cell of across the selection of cells.
- **Distributed** spreads the text out such that text is as evenly distributed as possible. If there is only one word, this option will center the text.
- **Justify distributed** is available when you have chosen a distributed Horizontal alignment. If you choose this option, you will not be able to use an indent with the distributed text.
**Vertical:** By default, Excel’s Vertical alignment is the bottom of the cell. There are four other options: Top, Center, Justify and Distributed. Top, Center, and Bottom are self-explanatory.

Justified and Distributed vertical alignments will wrap your text so that the contents fit within the column width and will place blank space between the lines as necessary to have the words touching the top and bottom of the cell. If there is only one line of text Justified text will remain at the top of the cell, Distributed in the Middle.

The **Indent:** option only available with the alignments that offer (Indent) in the list.

---

**Orientation**

These tools allow you rotate your text within 180 degrees, from left side to right side, as well as arranging each letter into a single column.

When you change the orientation, you the borders will follow the slant of the text.

For the least amount of distortion, try to stay with the 90°, 45°, 0°, -45° and -90° values.

---

**Text Control**

The text controls are toggle options. If the box is checked, the option is on; if the box is blank, the option is off. If a light gray check appears in the box, then some cells have the option and some do not; click once to turn on the option for all selected cells, and again to turn off for all selected cells.

- **Wrap Text** will keep text inside its own cell by creating multiple lines.
- **Shrink to fit** will reduce the size of the text such that it appears smaller when the column is not wide enough to show its true size.
- **Merge Cells** will join the selected (adjacent) cells into one cell. If there is data in more than one cell, Excel will only keep the information from the upper left cell.

---

**Right to Left**

This option specifies the reading order and alignment for different languages. Text is usually entered to the left of the cursor; in some languages, it is expected to go to the right of the cursor. This setting will adjust the flow of data, if your computer is set to the correct language.
**Number - Ribbon**

1. **Number Format** – Allows you to change the way numeric values are displayed on the spreadsheet. The drop down arrow gives you a list of the most common formats, including a More Number Formats option.

2. **Currency Style** – Sets the selected cell(s) to the Currency Style, this style keeps the dollar signs on the left side of the cell, and the number on the right side. The drop down arrow gives you a list of other currency formats, such as the Euro (€).

3. **Percent Style** – Sets the selected cell(s) to the Percent Style, this style has zero decimal places. Keyboard shortcut - Ctrl-Shift-%. This button can be reset through Cell Styles on the Home Tab.

4. **Comma Style** – Sets the selected cell(s) to the Comma Style, this style has a comma for every thousand and two decimal places. This button can be reset through

5. **Increase Decimal** – Increases the number of decimal places showing to the right of the decimal.

6. **Decrease Decimal** – Decreases the number of decimal places showing to the right of the decimal.

7. **More Options** – This button will open the Format Cells dialog window to the Number Tab.

**Number - Format Cells Window**

Most of the categories have options for you to choose. For example, with a Number category you decide how many decimal places, if there should be a comma separation at every 1000, and how to display the negative values.

Dates and Times are numbers, if a date loses its format, Excel will display the numerical representation of the value. You can change it back to a date/time format from the General drop down on the ribbon, or from the Date or Time categories in the Format Cells window.

There are a few Special formats such as Zip Codes, Phone Numbers and Social Security Numbers. If you type in 3525551234, and if the cell has a Special "Phone Number" format the cell will display (352) 555-1234.

It is possible to create Custom Formats. For example, if you wanted to create a column of UFIDs, you may choose to create a custom format of 0000-0000. This would ensure that all eight characters are required, and there is a hyphen in the middle. If we type in 123, we will see 0000-0123.

- 0 – required number
- # – optional number
- ; – designates format for negative numbers
- [red] – change color of text red
Cells Structures

There are a set number of cells within a Microsoft Excel worksheet. In the Ribbon versions (2007 and later), there are 16,384 columns and 1,048,576 rows. As you insert and delete structures, you are not reducing the number of cells, merely shifting where your data lies on the defined worksheet. Think about moving a painting around on a wall. You are not changing the wall, just the position of the painting.

Inserting

We use Insert to make new cells, columns, and rows. Excel determines what you are trying to insert based on your selection. If a full column is selected, Excel will assume you mean a full column and it will skip the Insert window.

You can insert a cell, row, or column by doing one of the following:

- Press Shift - Ctrl - = on the keyboard (ctrl plus)
- or from the Home tab, in the Cells group, choose Insert
- or open the Right-click menu and choose insert.

- To insert multiple at once, select the number of cells/rows/columns you would like to insert and follow the steps above.
- The size and format of the new space is determined by the previous (above or left) row or column.
- This will push the cells, columns, or rows away to the left and down to make room for the new cells.

Deleting

We use Delete to remove cells, columns, and rows. Excel determines what you are trying to delete based on your selection. You can delete a cell, row, or column by doing one of the following:

- Press Shift - Ctrl - - on the keyboard (ctrl minus)
- or from the Home tab, in the Cells group, choose Delete
- or open the Right-click menu and choose insert.

- To delete multiple at once, select the number of cells/rows/columns you would like to delete and follow the steps above.
- This will completely remove the structure, formatting and all, and the rows/columns/cells will shift into this place.
- If you only intended to delete the contents not the cells, undo and use the Clear Contents option instead.

View Freeze Titles

To keep the titles on the top and/or left side of the screen as you move around the worksheet, you need to freeze them into place. You can freeze the very first column, the very first row, or from your current position. If you want from your current position, everything above and to the left of the select cell will stay in place as you move around the worksheet. You will still be able to edit, the "freeze" refers to movement only.

You will find this option on the View tab, in the Window group. Once you have frozen your panes, you will have an option to Unfreeze to release the cells.
**Cell Size (Row Height/Column Width)**

You cannot resize one cell; the structure is dependent on the entire row and column where it resides. The Row Height and Column Width settings can be found under the Format menu in the Cells group of the Home tab.

**Adjusting with the Mouse**

When we resize we are growing away from the top left.

To resize the column, place your mouse cursor between the lines of the column headings. The current column heading is in a box; all you need to do is resize the box to make it wider. Put your mouse along the right side of the heading box until you see the resizing arrow pointing in two directions. Click and drag away from the column letter. When you let go of the mouse, the column will resize.

![Adjust Column Width](image)

To resize the row, place your mouse cursor between the lines of the row headings. The current row heading is in a box; all you need to do is resize the box to make it wider. Put your mouse along the bottom side of the heading box until you see the resizing arrow pointing in two directions. Click and drag away from the row number. When you let go of the mouse, the row will resize.

**Auto-fitting**

You can use the option found on the Format menu, or place your mouse cursor between the headings, with the two-way arrow to help resize, and double-click. The row or column should AutoFit to the largest data length within its structure.

- To resize multiple at once, select the cells you would like to fit and follow the steps above. If you are using double-click to auto-fit, the entire column/row structures must be selected.

**Gridlines**

**Printing Gridlines**

By default, the gridlines seen on the screen do not print, so we often use borders to show the boundaries of our cells. However, borders get tricky, and it does not take much to have them go awry. A better choice might be to have Excel print the gridlines.

You can find this option on the Sheet page of the Page Setup window, but it is easier to find on the Page Layout tab, in the Sheet Options group. From here, you can decide to print the Gridlines and the Headings, as well as decide if you want to view them on the screen.

**Headings** refer to the column letters and row numbers.

**Print Titles**

If you want your own custom titles, not the headings, use the Print Titles option on the Page Layout Tab in the Page Setup group.
Shortcut Keys

There are many ways to complete tasks in Excel: using the menus; using the toolbars; using the shortcut (right-click) menu; and using the keyboard shortcuts. Here is a list of some of the keyboard shortcuts available in Excel.

Ctrl-A – Select All
Ctrl-B – Bold
Ctrl-C – Copy
Ctrl-D – Fill Down
Ctrl-F – Find
Ctrl-G – Goto
Ctrl-H – Replace
Ctrl-I – Italicize
Ctrl-K – Hyperlink
Ctrl-L – Create a List/Table
Ctrl-N – New Workbook
Ctrl-O – Open Workbook
Ctrl-P – Print
Ctrl-R – Fill Right
Ctrl-S – Save
Ctrl-T – Create a List/Table
Ctrl-U – Underline
Ctrl-V – Paste
Ctrl-W – Close Workbook
Ctrl-X – Cut
Ctrl-Y – Redo
Ctrl-Z – Undo

Ctrl-1 – Format Cells
Ctrl-2 – Bold
Ctrl-3 – Italicize
Ctrl-4 – Underline

F1 – Help
F2 – Edit/Enter Mode
Shift-F2 – New Comment
Shift-F3 – Insert Function
Ctrl-F3 – Name Manager
F5 – Goto
F7 – Spell Check
Shift-F3 – Insert Function
Ctrl-F3 – Name Manager
F5 – Goto
F7 – Spell Check
Ctrl-F4 – Close Workbook
Alt-F4 – Exit Excel
Alt-Tab – Switch between Programs
Ctrl-Tab – Switch between Excel Workbooks
Alt-F – Opens File Menu
Alt-H – Home Tab
Alt-N – Insert Tab
Alt-P – Page Layout Tab
Alt-M – Formula Tab
Alt-A – Data Tab
Alt-R – Review Tab
Alt-W – View Tab
Alt-X – Add-Ins Tab
Alt-F8 – Macros

Ctrl-Shift-F – Format Cells Window
Ctrl-Alt-Tab – Increase Indent
Ctrl-Alt-Shift Tab – Decrease Indent
Ctrl-Shift-% – Percentage style
Class Exercise

- Vocabulary
  1. An Excel file is called a Workbook.
     ▪ Each workbook starts with one worksheet, but can have hundreds of worksheets.
  2. Ribbon broken into tabs (Home, Insert, Page Layout...)
     ▪ Tabs broken into groups (Clipboard, Font, Alignment)
  3. Name box and formula bar
  4. Columns Lettered, Rows Numbered, individual Cells
     ▪ Columns of a building, rows of chairs
  5. Worksheet navigation buttons, Worksheet tabs
  6. Status bar
     ▪ Excel behaves differently depending on what "mode" you are in

- Move around Excel
  1. Ctrl- →
     ▪ Column XFD (16,384 - 2^{14}) columns – SET AMOUNT)
  2. Ctrl- ↓
     ▪ 1,048,576 rows (2^{20} – SET AMOUNT)
  3. Ctrl-Home
     ▪ Always returns to the top

- Working area
  1. Type the letter "A" in cell G12 and press enter to accept
  2. From the View Tab choose Page Break Preview
     ▪ If needed, close the pop up message
     ▪ Notice most of the area is grayed out, but you can still click in the cells
  3. Click way down in the bottom right and type the letter "A", and press enter to accept
     ▪ The print area should snap to that cell. Every page in between A1 and that last cell will be printed.
  4. Move up one cell and press Delete (If you use backspace you will also need to press enter.)
     ▪ The print area should snap back into place
  5. From the Workbook Views in the View Tab choose Normal view
  6. Ctrl Home
  7. Delete data in G12
- Change Zoom
  1. From the View tab, click on Zoom button to change to 200%,
  2. Change Zoom Manually to 150%
  3. Play with + & - buttons on the zoom slider in the bottom right of the window
     - See Page 4 of this handout
  4. Change Zoom back to 200%
  5. Ctrl-Home

- Moving around
  1. Use keyboard arrows to move up, down, left and right
  2. Use enter and tab to move down and over
  3. Use Shift-Enter and Shift-Tab to move up and back

- Selecting Multiple Cells with the mouse
  1. Drag mouse from middle of a cell diagonally across to another cell

- Difference between Tab/Enter and Arrows
  1. Make a selection of cells (about three by three)
  2. Use the enter key to move between the cells
  3. Use the tab key
  4. Use an arrow key
     - Tab and Enter will stay within the selected range. Arrow keys like the mouse, are pointers. They point to a location. Enter and tab are meant for data entry, they accept and move on.

- Selecting Multiple Cells with the keyboard
  1. Click in a cell, hold down the Shift key and click into another cell.
  2. Let go of the Shift key and click anywhere to drop your selection.
  3. Click in a cell, hold down the Shift key and at the same time use the arrow keys

- Entering Text (Enter Mode)
  1. In all lower case letters, type in cell B2
     ▪ big city store
     - Notice the status bar will change as soon as you begin to type from READY to ENTER

- Editing Text (Edit Mode)
  1. Double-click to "get inside" cell B2
  2. Change first letter of each word to uppercase
     - Big City Store
  3. Press Ctrl-Enter to accept.

- Editing Text (Edit Mode)
  1. Click inside the Formula bar, and notice your status is now Edit.
     - The Cancel and Accept buttons between the name box and the formula bar are available when you are in Edit, Enter, and Point modes.
Entering Text in Consecutive Cells
1. Type in cell C2
   - Sale
2. Big City Store will be cut off by the Sale. If you're in cell B2, you can look at the Formula bar to see the true contents still read "Big City Store"

Adjust Column Widths
1. We cannot change the size of one cell, so we need to adjust the column
   - Place your mouse between the column headings B and C and you will see the ➕
   - Drag away from column heading B to make the column wider
   - Drag toward column heading B to make the column skinnier
     - Make it so you can only see Big City
   - Move back to the resize double arrow and double-click on the line to AutoFit
   - Now, AutoFit Column C

Copy and Paste
1. Copy Cell B2, notice the dashed lines, the marquee, around the cell
2. Paste into another cell, paste into another cell (paste a few...)
3. Read the status bar, press enter to do a 'final paste'

Cut and Paste
1. Cut Cell C2, notice the cell does not delete, but we have a marquee
2. Paste into an empty cell
   - Notice the original NOW disappears
3. Cut and Paste "Sale" back into C2

Fill Handle
1. Take Fill handle from bottom left of cell C2 and drag it down two cells
   - Creates two more 'Sale' cells
   - Fill handle will be discussed at length in the next class
2. Click anywhere to drop your selection

Moving Cells
1. Mouse over the edge of cell C2 until you get the arrows
   - Click and drag to a blank cell to move the cell contents

Duplicating Cells
1. Pick up a cell as if to move it and hold down the CTRL key at the same time, move to an empty cell. Let go of the mouse BEFORE the keyboard

Use Copy/Cut & Paste or Move/Duplicate Cells to organize your screen
1. Move all the Big City Stores to Column B, Rows 2-8
2. Move all the Sales to Column C, Rows 2-8
3. Delete all extras

Move the dataset
1. Select all the data, move the mouse to the edge of the selection to get the arrows
2. Drag the whole block into columns D and E
3. Undo the move
- Insert Columns
  1. Right-click on Column Heading B, choose Insert
  2. Do it again so now data lives in D & E

- Formatting Fonts with Home tab,
  1. See page 8
  2. Format Font (Cell D2)
  3. Format Size (Cell D3)
     - Custom Sizing (size 15)
     - Use Increase and Decrease buttons
  4. Format Bold (D4), Italics (D5) and Underline, Double Underline (D6)
  5. Format Color (D7)
     - View MORE COLORS
  6. Edit Cell D8
     - Double-click to "Get Inside" the cell
     - Double-click each word to format
     - Bold: Big, Italicize: City, Underline: Store
     - Notice the text in the formula bar is not formatted

- Format Fonts with Format Cells window
  1. Format Cell E2 using "More" Button
     - Comic Sans, Bold, 14, Double Underline, Green

- Use Format Painter
  1. In cell E2, click on the format painter
     - Dashed Marquee means we are copying
     - Click on cell D2, all changes happen at once
  2. Try painter again, it turns off
     - Double-click to Keep on, press Esc (escape) to stop
  3. Change all cells to this font
     - Cell D8 won't format, Delete

- Format Column/Row
  1. Click on Column Letter E to select whole column
     - Change color to Red
  2. Right-Click on Row Number 4 to select whole row
     - Change color to Blue

- Format All
  1. Click on blank gray square between Column A and Row 1 to select the whole spreadsheet
     - Open the "more" fonts (Format Cells Window)
     - Choose Normal Font (Click the box as many times as needed to show a check mark)
     - Click OK to see the changes
- Click on the Plus sign next to Sheet 1 to create Sheet 2

- Zoom to 200%

- Starting in B2 type:
  1. B2 - Text
  2. B3 - 123
  3. B4 - *
  4. B5 - 2/1

  5. The date changes to a different format, but the formula bar shows that Excel assumed the date was for the current year.
  6. Notice the data is on different sides of the cell
     - (text, number, text, date)
     - Text on the left
     - Numbers & Dates on the right

- Alignments with Toolbar
  1. Select Column B
  2. From the Alignment Group on the Home tab try the different alignments
     - Left, Center, Right, None (Not left/not center/not right)

- Indent
  1. Bold and Underline B2: Text
  2. Select B3:B5
     - Increase Indent
     - Decrease Indent
     - Center Text, Increase Indent, pops back to the left
     - Decrease Indent
     - Right Align Text, Increase indent

- Alignments with Menu
  1. Select all of Column B
  2. Open the more alignments (format cells) window
  3. Change the Horizontal option to Fill
  4. Click OK and see how the cell contents repeat
     - Type into a cell in column B to see the changes
     - Careful of ones like -= or -=, Excel will think you want an equation and will give you an error message. If you want this pattern, you will need a single quote in front.

- Delete Column
  1. Select Column B, press delete on keyboard
  2. Type A in cell B2 and Press enter
     - Cell should repeat AAAAAAAAAA
     - Delete on the keyboard erases the cell contents, not the formatting
  3. Right-click on column B and Choose DELETE
     - Column will be physically removed, along with its formats
- Copy from another worksheet
  1. Turn to Sheet 1
     - Select the first two Big City Stores
     - Copy
  2. Turn to Sheet 2
     - Paste into Cell B2 on Sheet 2
  3. DO NOT ADJUST COLUMN WIDTHS

- Try cell alignments to see what happens when cell's not big enough
  1. Left, center, right, none

- Center Across Selection
  1. Select B2:F2
  2. More Alignments
     - Horizontal: Center Across Selection
  3. Click OK

- Center and Merge Selection
  1. Select B3:F3
  2. More Alignments
     - Horizontal: Center
     - Text Control: Merge Cells
     - Notice in the Alignment group, there is a Merge and Center button

- Copy 2 Big City Stores from Sheet 1
  1. Paste into Cell B6 on Sheet 2

- Shrink to fit
  1. Click in Cell B6
  2. Open format cells box, Alignment tab
     - Text Control Shrink to Fit
  3. Click OK
  4. Adjust Column Widths wider, narrower

- Wrap Text
  1. Click in Cell B6
  2. Open format cells window, Alignment Tab
     - Text Control turn off Shrink to Fit
     - Text Control turn on Wrap Text
  3. Adjust Column Widths so line goes through the Y in CITY
     - Notice in the Alignment group, there is a wrap text button

- Forced "Enter"
  1. Double-Click in Cell B7
  2. Place your cursor in front of the word City
  3. Press ALT-Enter to force the text to the next line
  4. Repeat in front of Store
  5. Adjust column widths
  6. The bottom of the formula bar can be dragged down to read multiple lines
- Vertical alignment
  1. Adjust the column widths so B6 and B7 match
  2. Click in Cell C6, type Sale
  3. Press enter or accept
  4. In cell C6, change the vertical alignment
     ▪ The Top/Middle/Bottom are above the left/center/right buttons

- Text Rotation
  1. In cell C6, click on the Orientation button to slant text
     ▪ Looks like an angled AB next to align bottom
  2. Open Format Cells Window to view all ORIENTATION options

- Click on the Plus sign next to Sheet 2 to create Sheet 3

- Adjust the zoom to 200%

- Decimal places
  1. In cell B2 type:
     ▪ 1.928374650 and press enter
     ▪ This is not the number that shows
     ▪ Move back to that cell and see the true number in the status bar
  2. Use the Increase Decimal button to show the original number

- Too many digits #######
  1. Resize the column to half its current width
  2. Notice the number is still in the formula bar, but the cell displays hashtags. This means the cell is too skinny to display the full number.
  3. Double-click between the column headings to auto fit the cell contents

- Format numbers buttons
  1. Use the Decrease Decimal button until there are no decimals showing
  2. Click on the Dollar sign button
  3. Click on the Percentage button
  4. Click on the Comma style button
     ▪ Edit cell, remove decimal place, Accept
  5. From the drop down list in the number group, click General to remove all formatting

- Format Special Numbers
  1. From the corner of the number group choose the More button
  2. Click on the different options
     ▪ Special -> SSN
     ▪ Click OK
- Click on the Plus sign next to Sheet 3 to create Sheet 4

- Adjust the zoom to 200%

- Fill in data selection
  1. Select B2:D4
  2. Enter numbers 1-9, press enter to maintain the selection
  3. Press delete to clear what you typed
  4. Make sure you still have your nine cells selected
     - Type the number 1
     - press Ctrl-Enter to accept
     - This should enter a 1 into all nine cells at once
  5. Center the numbers

- Format Background Colors
  1. While the values are still selected, click on the fill bucket in the Font group
  2. Open the menu and hover to see a preview of choices
  3. Hover over the white
     - No gridlines
  4. Choose No Fill

- Add Borders
  1. Click on the borders button in front of the bucket in the Font group
  2. Choose ALL BORDERS
  3. Return to the fill and find one you like
  4. Click outside the select to see the result

- Custom borders
  1. Select the dataset (B2:D4)
  2. From the Borders drop down, choose More Borders
     - Pick a line, pick a color, pick a location to put the lines
  3. Click Ok and click outside the selection to see the results

- Clear Formatting
  1. Select the entire sheet (space above Row 1, left of Column A)
  2. In the editing group on the far right of the Home Tab, look for the Clear button
  3. Choose Clear -> Clear Formats

- Format Fill
  1. See Page 10
  2. Select the dataset (B2:D4)
  3. Ctrl-1, or right-click Format Cells
  4. Turn to the Fill Page
     - Fill Patterns
     - Fill Effects

- Close, Don’t save