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Departments Form
When you open the Departments table you can see that it
is in a relationship by the expand (+) buttons at the
beginning of each record. When you click on the button
Access will show you the employees that work for that
department. One department can have Many employees.
‐

If the table is participating in multiple relationships,
the first time you click on the expand button,
Access may ask you to choose the subdatasheet.

‐

The Subdatasheet can be changed or removed
from the More menu in the Records group on the
Home tab.

‐

The attached Subdatasheet will embed a copy of the
table inside an instant Form. This is fine for simple
data entry, but if you want to do anything beyond,
you may be better off creating a subForm.

Create an instant Form with Subdatasheet
1.

Select Departments Table

2.

From the Create Tab, in the Forms group, click the Form button

3.

Close and Save as Departments
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Employees Forms
The Employees table has several data types. Looking at the design
and the data we can see several differences.

‐

Emp ID is the AutoNumber key in this table, but we don't see it in the Datasheet view.
This is because the field has been hidden. Right‐click on any fieldname in the Datasheet
and choose Unhide fields to show and hide the columns of this view.

‐

Field Name vs. Caption – The titles showing in the Design view have "Emp" in front of
each field name, but the titles in the Datasheet view do not. This is because of the Caption
property, shown above.

‐

Yes/No fields appear as check boxes in the datasheet view.

‐

Attachment fields show as a paperclip with the number of attachments in parentheses.

‐

In the Datasheet view, the Dept ID is showing the name of the department, but in the Design
view it's listed as a number. This is a clue that the field has Lookup properties.

Create an instant Form with Split Form
Split Forms shows the Form view and datasheet view in the same
window. The split settings can be adjusted in the Form properties. This
includes where the datasheet appears (orientation), and if you can edit
the data in the datasheet portion.
1.

Select Employee Table

2.

From the Create Tab, in the Forms group, click the More Forms option, choose Split Form.


3.

The top half of the window will vary based on your window/screen size.

Close and save as Employee Split Form
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Create an instant Form with Multiple Items
Multiple Items Forms show multiple records like a datasheet, but each record can have Form objects,
such as a button on each record, and can display Formatting you would not see in the datasheet view,
such as images instead of the attachment paperclip.


The Form Wizard calls this a Tabular layout.



To modify a single record Form into a multiple items Form change the Form property
Default View to Continuous.

1.

Select Employee Table

2.

From the Create Tab, in the Forms group, click the More Forms option, choose Multiple Items

3.

Close and save as Employee Multiple Items
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Create a Form with Wizard (Justified)
The wizard allows us to pick the fields from one or
more (related) tables and queries, set a layout,
and automatically saves the result.
1.

Select Employee Table.

2.

From the Create Tab, in the Forms group,
click the Form Wizard.

3.

Use the double arrow to bring over all the
fields from the employee table, then use
the single arrow to exclude the Dept ID.

4.

Choose the Justified layout.
This layout will try to fit fields on
the same row whenever possible.

5.



Columnar – Single Form



Tabular – Multiple Items



Datasheet – Table view

Title the Form Employees Justified.

Access looks at the field size property to decide
the size of the text box. If you look in the table,
you'll see the field size for the names is set to 255.
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Patients Form
The wizard and instant Forms are a good starting point, but there's nothing quite like building your own.
Create a Form in Design view
1.

From the Create Tab, in the Forms group, click the Form Design.

2.

Open the property sheet.
‐
‐
‐
‐

3.

Click in the Grid to see the Section Detail properties.


4.

5.

Change the Height property to 2"

Click outside the grid to see the Form properties.


Change the Width property to 5"



Change the Record Source property to Patients



Allow Datasheet View: No; Allow Layout View: No

Open the field list with the Add Existing Fields button on the Design tab.


6.

Button on the far right of the Design tab
Right‐click menu (almost anywhere)
Double‐click (almost anywhere)
Keyboard shortcuts – Alt‐Enter and Function key F4

If you need a field that is not showing on the Field List you need to adjust your record
source. The field has to exist in a table or Query to be on this list. Avoid using the "Show All
Tables" option, as that will embed a hidden Query and may cause issues later.

Drag field Pt Med Rec from Field List onto the Form approximately 1” down, 2” across.



Access drops two boxes on the Form. The left box is called the Label, the right is a Text Box.



Labels appear the same in every view, and
will show the caption property if one was set
in the table.



Text boxes show the field name in the Design
view and the data in the Layout and Form
views.



Be aware that the label always drops over an
inch away from the text box, so when you add
the fields from the field list, remember to give
yourself a buffer of space.
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Resizing
When you place your mouse on the any of the selected objects sizing handles – the small boxes at the
top, bottom, left right, and corners of your selection – you will get a double arrow (
). Click
and drag the mouse and the box will resize the selected items. Access anchors in the upper left corner,
so you will resize your object from this corner.
The Shift key used in conjunction with the arrow keys on the keyboard, allow you to adjust the size of
your object. Using Shift and Ctrl will resize a quarter of a grid point at a time. The Arrange has a Size
group where you can adjust the objects relative to each other.
Moving with the Mouse
When you place your mouse anywhere on the edge of the text box, between the sizing handles, your
mouse arrow will turn into the move pointer ( ). This pointer also appears when you click and hold on
an unselected object. When you click and drag the mouse while the pointer shows this arrow, both the
label and the text box will move. Watch the shadow in the ruler to see your selection.
The upper left corner of the label and the text box both show a square larger than the sizing handles,
this is to identify the link between the text box and its label. When you place the mouse in this large
square, your pointer will still show the moving pointer ( ), however when you drag from this corner the
item will move independently of its partner text/label box. To separate a label from its text box, you can
cut and paste the label. Again, watch the shadow in the ruler to see your selection.
Moving with the Keyboard
You can move items one grid point at a time by using the arrows on the keyboard; you can move an
object a quarter of a grid point by pressing Ctrl in conjunction with the arrow keys.
Blank Text Boxes and Labels
The Text Box and Label controls can be found in
the Controls group on the Design tab. Click once
on the option, then click where you would like
the control to be placed on the Form. The text
boxes will be unbound because they are not
linked to the datasource or a Formula.

Build a Form in Design view
1.

In the Design view, delete the
Pt Med Rec text box and use
the Field List (Add Existing
Fields) to create this Form:


Try to keep the Form 5"x2"



Make sure you can view all
the labels in the Form view



Save as Patients
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Organize Form Controls
1.

In the Design view, try to clean up the Form. Use the tools on the Arrange tab to Align and space
the fields. Many of the Align, Size, Position, and Layout groups can be found through the right‐
click menu.

Making Multiple Selections
‐

Shift Key: To select more than one item in the design view, click on the first item and then hold
down the shift key on the keyboard and click on each subsequent item you wish to select. If you
mean to include the labels, don’t forget to click on them as well.

‐

Items in a Line: When the objects you would like to select are all in a row or column, you can
click in the ruler and Access will select everything in the path of that selection.

‐

Selection Box: If you click in a part of the grid that is unoccupied by any objects and drag the
mouse over the objects you would like to select, you will see a selection box being drawn. Any
items that the selection box touches will be selected be careful with
this, especially in Reports where there are so many lines.

Arrange Size and Space
Size ‐ The To Fit option is the same as double‐clicking on the sizing handles, it
will fit all the selected objects to their own best fit. It will always adjust the
height, but for controls bound to a control source, Access will only adjust the
height, not the width.
Tallest and Shortest are the vertical sizes, Widest and Narrowest are the
horizontal sizes. As you move and align objects it's possible they will shift off
the grid. The To Grid option helps keep controls lined up.
Space ‐ The spacing options will only be available when you have multiple items
selected. We use this instead of "align center" to adjust the spacing between
the selected objects. Text boxes will often move their labels with them. To
adjust the spacing of the text boxes, use your shift key to ONLY select those
controls before you change the spacing.
Grid ‐ The Grid helps give us a visual alignment, but when a Form/Report
becomes complicated, sometimes it's nice to turn off the Grid so you can see
more details. The Snap to Grid option will help line up objects as you move
them around the Form/Report.
Grouping ‐ Several objects can be grouped together so when they are moved or
deleted, Access will take the whole 'group'.
Aligning Objects
These options will only be available if more than one object is selected. Unlike the
other Microsoft Office products, Access’s Align feature has no Center or Middle, to
adjust your controls it would be better to use the vertical/horizontal spacing found
under the Size/Space button.
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Navigating Records in the Form
Tab Order
The Tab Order button opens a window to help you adjust the order the keyboard will move through the
controls in the Form View, using the Tab, Enter, or Arrow keys.
If the Form is aligned properly, you can usually press the Auto Order button at the bottom of the
window. To customize the order use the small gray select box in front of each control name. This
window can be frustrating because those little gray boxes are all you can click on in the fields.

1.

In the Form view, navigate through the fields (text
boxes) using the keyboard.
‐
‐
‐

Enter, Tab, Down, Right ‐> Forward
Shift‐Tab, Up, Left ‐> Backwards
F2 to edit, or click inside

2.

In the Design view, switch the placement of the
First Name and Last Name. Drag, Drop, Align.

3.

In the Form View, navigating through the fields we
can see the tab order is out of sync.

4.

In the Design view, adjust the Tab Order.


5.

6.

Tab Order can be found on the Design tab or by
right‐clicking in the Detail section grid.

Try to rearrange the fields into alphabetical order.


Address through Zip



Click on the box in the front of the field name.
Click in the same box and drag. Think "Select
Then Move".

Click on the Auto Order button. If necessary, adjust the fields.

Command Buttons
1.

In the Design View, expand the height of the detail section to around 2.5".

2.

Click the Command Button option in the controls listed on the Design tab.

3.

Click on the Form where you want the button to appear. Remember you are dropping the top
left corner of the button to be. This should launch a Command Button Wizard.


4.

If a button is created, but the wizard does not appear, open the control gallery and choose
the Use Control Wizards option

Create three buttons.


Go to Next Record



Go to Previous Record



Close Form
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Command Button Wizard
Step 1: What do you want to happen?
Record Navigation – Moving between or
searching for records
Record Operations – Adding, deleting,
duplicating records
Form Operation –Close Forms, Open Forms
(this is how we make menus, open Form
buttons!), Filter Forms
Report Operations – Print Reports, Preview
Reports, Email Reports
Application – Exit Access
Miscellaneous – Run Queries and Macros

Step 2: How do you want the button to look?
Text – You can put text on the buttons. If you
want a Hot Key option, like the Back and Next
button in this wizard, put an & in front of the
letter you want.
Picture – The wizard will offer you common
images used with the action you chose. You
can click on the Show All Pictures button to
see all the images in the button library. You
can put any BMP image on a button, use the
Browse button to find your picture.
Both?! – Yes, you can put a picture and words
on the same button, but not through the
wizard. Look for the Picture Caption
Arrangement property after the button is
created.

Step 3: What do you want to name it?
Access doesn't care what you name your
database objects, again naming is for our
convenience. The name you choose here will
be what appears on the object list in the
properties and in the Tab Order window.
Make your life easier and use a good name!
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Patient Reports
Instant Report
There's only one Instant Report, we'll have to use the wizard to see more Report types.
1.

Select Patients table

2.

From the Create Tab, in the Reports group, click the Report button.


3.

Adjust widths so the fields fit within the margin guides. If anything goes awry, Undo.

Save as Patients

1. Select the table Patients
‐ Create Tab, Report
‐ Explore Layout View
‐ Close and Don't Save

2. Report Wizard (see pg 9‐10)
‐ Columnar


Table Patients using all the fields



No Grouping



No Sorting

Report Wizard
1.

Select Patients table

2.

From the Create tab choose Report
Wizard.


Choose all the fields (next)



No Grouping (next)



No Sorting (next)



Layout: Columnar, Portrait, Adjusting
field widths



Title: Patients Columnar

3.

Repeat steps 1 and 2 for Layout: Tabular

4.

Repeat steps 1 and 2 for Layout: Justified.


Justified looks bad because of the
field sizes.
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Report Layout Columnar

Report Layout Tabular

Report Layout Justified
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Field Sizes Matter
Remember when you go through the instant
Form/Report tools or wizards Access looks at the
Field Size property to determine how big the text
boxes need to be. We can continually readjust
the text boxes every time we use these tools, or
we can make sure our field sizes are more
appropriate.
1.

Close all database objects (tables, Forms,
Reports…).

2.

Open the Patients table in Design view.

3.

Change the field sizes:








Pt Med Rec
Pt Last Name
Pt First Name
Pt Address
Pt City
Pt State
Pt Zip

10
50
50
255
50
2
15

4.

Close and Save the table, confirm it is OK if data is lost.

5.

Repeat the Report Wizard using the Justified layout.

6.

Save as Patients Justified 2.
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Report Sections
1.

Select Patients table

2.

From the Create tab choose Report Wizard.






Choose all the fields (next)
No Grouping (next)
No Sorting (next)
Layout: Tabular, Landscape, Adjusting field widths
Title: Patients

3.

Set Zoom to four pages

4.

Report Sections

5.



Report Header, "Patients" ‐ first page only



Page Header/Footer, "Med Rec, Last Name, First Name..." on every page



Detail, each line of data every record

The Design view of the Report shows the
four sections within the Report.


Right‐click on the Report to go to the
Design view.
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Add a Report Footer
1.

In the Design of the Report, stretch the Report Footer section. If you cannot drag the resize area,
use the Section properties.

2.

Right‐click inside the Report Footer section and choose a fill color.

3.

Preview the Report to see where the Report footer will appear.


Last page, after the last Record Detail, before the Page Footer.

4.

From the Controls on the Design tab, choose the Label. Click to turn the tool on, and click where
you'd like the box to appear.

5.

Type "Created by [your name]"

6.

Use the Format text tools on the Home or Format tab to adjust fonts, sizes and colors.

7.

Preview the Report.

8.

Close and Save the Report. The wizard already saved it, so you won't have to name the Report.
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Create a Report in Design view
1.

From the Create Tab, in the Reports group, click the Report Design.

2.

Open the property sheet.

3.

Click in the Grid of the Detail Section to see the Section properties.


4.

Change the Height property to 2"

Click outside the grid to see the Report properties.


Change the Record Source property to Patients

5.

Open the field list with the Add Existing Fields button on the Design tab.

6.

Double‐click on Pt Med Rec in the Field List.

7.

Go to the Print Preview to see the result.


0.25" margin + 0.25" Page header



+ 2.00" for each record (Detail)



This would work for a columnar Report.

Set up a Tabular Report
1.

In the Design view, move the Pt Med Rec label and text box as high as
you can in the detail section


2.

Or set property Top to 0"

Reduce the height of the Detail section as far as it will go


Or set property height to 0". It can't be zero because there are
objects in the way, but it will make it as small as possible.

3.

Go to the Print Preview to see the result.

4.

Adjust the spacing in the detail section so the data isn't so tight.


5.

You can eyeball this, but I would select the field, press the down
arrow key on my keyboard four times, press the up arrow 2 times.
This stretches out the detail section and re‐centers my field within
the given space.

Move the label to the Page Header.


The label is attached to the text box, to sever their connection use
Cut. Cut the label from the detail section, paste in the Page Header
section.



Use your align and size tools to make the Report organized.

6.

Make a matching Last Name column.

7.

Go to the Print Preview to see the result.

8.

Close and Save as Patients Draft 1.
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Working with Table Structures
1.

From the Create Tab, in the Reports group, click the Report Design.

2.

Open the Property Sheet (button on the Design tab).

3.

Click outside the grid to see the Form properties


Change the Record Source property to Patients

4.

Open the field list with the Add Existing Fields (button on the Design tab).

5.

Click on Pt Med Rec and Shift‐Click on Pt Zip

6.

Drag the Selection onto the Form

When you drag the fields onto the Form/Report, each textbox is a single unit, you can resize and move it
independent of the other objects. Sometimes that's good so you can customize your Form/Report,
sometimes it's bad because resizing one thing requires you to resize EVERYTHING.

Access provides table structures within the Form. They are a little cranky, but usually worth the effort.
7.

With all the fields selected, click on the Stacked option on the
Arrange tab.


Click in the grid to drop the selection. Then click on one field
to see that you're in a "table".



The plus sign in the corner is a "Table Move Handle", it will
select everything in the table. You can use it to move the
table structure.



Once you're in a table structure, most of the Arrange tab will
be enabled.

8.

Swap the first and last name.

9.

Select the whole table and click the Tabular option on the
Arrange tab.


This is much easier than individually moving the labels
into the page header one at a time.

10.

Swap the first and last name again.

11.

Select the whole table and choose the Remove Layout
option.


12.

This removes the table structure, but keeps the object
placements.

Close and don't save
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Sorting Data on a Report
The Sort options are available in the Data view of Tables, Queries, and Forms, but not in a Report. The
Sort Order of a dataset can be arranged in the Design view of a Query. If you want to limit the data on a
Report or have it display the data in a specific order, you may want to set up a Query. It is possible to
sort a Report, but it has to be set in the structure of the Report.
Quick Filter
1.

Open the Report Patients in Report view.


Notice the Sorting tools are disabled, but the filters are working.

2.

Right‐click on Waldo in the City Column. Choose Equals Waldo.

3.

Click the Toggle filter button on the Home tab.


Filters are temporary. If you close the Report and reopen it, all the data will return.

Sort Order
1.

Go to the Design view of the Report.

2.

From the Design tab or from the right‐click menu , open
the Sorting and Grouping Options


Depending on where you find the tool it has slightly
different names: Group & Sort; Sorting and Grouping;
Group, Sort, and Total.

3.

‐ Sort by City "with Z on top".

4.

‐ Sort by Last Name "With A on top".

5.

‐ Close and Don't Save.

Quick Sort in Layout View
1.

Open the Patients Report in Layout view.

2.

If needed, open the Group & Sort pane.

3.

Right‐click on a city and choose Sort Z to A.

4.

Right‐click on a last name and choose Sort A to Z.


This replaces the City sort, only one sort level this way.

Label Wizard
Labels are usually used to create folder labels, mailing labels, and name tags. You can create these
through a Mail Merge in Microsoft Word, or here in Access by using the Label Wizard. In Word, you're
able to modify the final result; in Access, you cannot modify the data on a Report.
Make sure you select the correct database object in the Navigation Pane, this wizard does not give you a
chance to change the record source.
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The label product number should be listed
on the box of labels.
1.

Select Table Patients

2.

From the Create tab, in the
Reports group, choose Labels


find 5160



Leave Font set as is



Build Label using keyboard as
needed



No Sorting



Save As Labels Patients 5160

You may get an error message. This
sometimes happens because labels are
often close to the edge of the page.
Usually the Report will print without a
problem, but this error message may
come up as a warning each time you run
the Report.
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Same Report, Different Data
Happens all the time. You have a beautiful Report, but it's got the wrong data. You can try to recreate
the Report, but that's more work than needed.
Make the Query
Again, if you only want part of the data, you should create
a Query that produces the set you want.

1.

From the Create tab choose Query Design.

2.

From the Show table List, choose Patients, Add and
Close

3.

Add all the fields at once with the * option.


4.

5.

Double‐click on the * at the top of the Patients
Table. The asterisk (*) represents the entire
dataset.

Add Pt City.


Double‐click on Pt City.



Since the * already brought a City field,
uncheck the Show option.



Set the criteria to Not "Gainesville".

Save as Patients not Gainesville.


Should be 21 records.

Copy the Report
You can open the original report and use the Save As option, but copying and pasting the original report
often produces better results. You may need to change the Report Property Caption to match the new
report.
1.

Right‐click on Labels Patients 5160 and Copy.

2.

Right‐click anywhere in the navigation pane and choose Paste.

3.

Paste as: Labels Patients 5160 ‐ Not Gainesville.

4.

Right‐click on the new report and go to the Design
view.

5.

Open the property sheet.

6.

Change the Record source property for the Report to
Patients not Gainesville.

7.

Preview the Report.


8.

If needed, say OK to the margin error message.

Save!!
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